Version compatibility

From SuperMemopedia
Jump to: navigation, search

Question

What can I do with this error:

"To open this collection you need a newer version of SuperMemo!
Collection: D:\SM2006  ????\SYSTEMS\ABC OF SUPERMEMO 2006
Current version: SuperMemo 2004 Freeware Beta (Build 12.1 Beta, Mar 23, 2011)
For more information see www.supermemo.com
Abort?"

--------------------DETAILS--------------------
SuperMemo 2004 Freeware Beta (Build 12.1 Beta, Mar 23, 2011)
Time: ?????? 07, 2011, 23:30
--------------------ELEMENT CONTENT

--------------------SYSTEM DATA
Windows XP 5.1 (Build 2600) Service Pack 3
Internet Explorer 7.0 (0)
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
User language: he
System language: he
Browser language: he
User: USER
Computer: MYCOMP
Memory Used: 771.852 KB
Active Code Page: 1255
OEM Code Page: 862
Host: MyComp
Host HD: B4B5-23DB
IP Address: 10.0.0.5
Network installed 

Answer

To open this collection you need a newer version of SuperMemo means that you are trying to use an older version of SuperMemo to open a collection with learning material created with a newer version of SuperMemo. Usually, old SuperMemo cannot use new SuperMemo collections directly (i.e. with File : Open collection). In your case, SuperMemo 2004 Freeware is trying to open a collection of newer SuperMemo, most likely SuperMemo 2006 (as indicated by the name ABC of SuperMemo 2006.